The memories of Oracle 9.2 on AIX 4.3.3 are as follows:
1. Check physical memory: (RAM> = 512 MB)
# lsattr --l sys0 -a realmem
Realmem 1048576 Amount of USABLE Physical Memory in Kbytes False
#
2. Check the SWAP space: (equal to physical memory or 1G, it is best to be large)
# lsps -a
Page Space Physical Volume Volume Group Size% Used Active Auto Type
HD6 HDisk0 rootvg 2048MB 1 YES YES LV
#
3. Check disk space, mainly pay attention to two points:
a) Install 9.2, mainly to store Oracle Code, this space is recommended to 4G, or bigger.
b) In addition, in the process of installing Oracle, Oracle Universal Installer requires approximately 400M to temporary space, you can use the system default / TMP directory, you can also set up the environment variable TMPDIR to specify a directory with sufficient space, or in the installation process Specify a temporary directory with enough space
Such as:
TMPDIR = / oratools
Export Tmpdir
In general, Oracle's installation files are placed on the built-in disk, so we need to look at the space of the built-in disk:
# Lsdev -cc disk
HDisk0 Available 40-60-00-4, 0 16 Bit LVD SCSI Disk Drive
HDisk1 Available 14-08-L SSA Logical Disk Drive
#
We see that hdisk0 is a built-in disk, and now determines its size:
# lspv hdisk0
Physical Volume: HDisk0 Volume Group: rootvg
Pv Identifier: 000ca13f7ebe3b7e vg identifier 000ca13f7ebe3e67
PV State: Active
Stale Partitions: 0 Allocatable: YES
PP Size: 32 Megabyte (s) Logical Volumes: 11
Total PPS: 542 (17344 Megabytes) VG Descriptors: 2
Free PPS: 217 (6944 Megabytes) Hot Spare: no
Used PPS: 325 (10400 megabytes)
Free distribution: 108..20..00..89
Used distribution: 01..88..108..108..20
#
4. Check the version of the OS, two methods:
You can use the oslevel command to determine the current AIX version,
# osLVEL
4.3.3.0
#
Or you can also use Oslevel -R to determine the current AIX version and ML (The Maintenance Level of the System):
# oslevel -r4330-09
#
This result is similar to the current ML:
$ instfix -i | grep ml
All FileSets for 4.3.0.0_Aix_ml..
All FileSets for 4.3.1.0_aix_ml..
All FileSets for 4.3.2.0_aix_ml..
All FileSets for 4320-02_Aix_ml.
All FileSets for 4.3.3.0_Aix_ml..
All FileSets for 4330-01_aix_ml.
All FileSets for 4330-02_aix_ml.
All FileSets for 4330-03_Aix_ml..
All FileSets for 4330-04_Aix_ml.
All FileSets for 4330-05_Aix_ml..
All FileSets for 4330-06_aix_ml..
Not All FileSets for 4330-07_Aix_ml at all Found.
All FileSets for 4330-08_Aix_ml.
All FileSets for 4330-09_Aix_ml..
All FileSets for Aix43ml..
$
It can be seen that we are AIX 4.3.3, ml is 09
5. Check if the OS is 64 bit:
If it is a 64 bit bit OS, you can load 32 bit or 64 bit Oracle 8i, but 32 bit of OS can only load 32 bit of Oracle; because Oracle 9.2 does not have 32 bits, so we must verify our OS is 64 Bit OS:
There are two ways:
# locale64
LANG = C
LC_COLLATE = "C"
LC_CTYPE = "C"
LC_MONetary = "c"
LC_NUMERIC = "C"
LC_TIME = "C"
LC_MESSAGES = "C"
Lc_all =
#
or
# bootinfo -y
64
#
6. Take a look at the os PATCH is not enough.
Oracle's documentation, for AIX 4.3.3 requirements at least in ML 09, and IY24568, IY25282, IY27614, IY30151 These four patches, but in fact, we also need a IY30927, and the document says this package is just useful with the CPU. Efficiency-related bags, don't, but I have installed experience, must, otherwise I will have problems. If the above package does not exist, then it will be required to download the following site DOWNLOAD:
http://tesupport.services.ibm.com/server/fixes
$ instfix -i | grep ml
All FileSets for 4.3.0.0_Aix_ml..
All FileSets for 4.3.1.0_aix_ml..
All FileSets for 4.3.2.0_aix_ml..
All FileSets for 4320-02_aix_ml werefact.all filesets for 4.3.3.0_Aix_ml..
All FileSets for 4330-01_aix_ml.
All FileSets for 4330-02_aix_ml.
All FileSets for 4330-03_Aix_ml..
All FileSets for 4330-04_Aix_ml.
All FileSets for 4330-05_Aix_ml..
All FileSets for 4330-06_aix_ml..
Not All FileSets for 4330-07_Aix_ml at all Found.
All FileSets for 4330-08_Aix_ml.
All FileSets for 4330-09_Aix_ml..
All FileSets for Aix43ml..
$
Obviously, our AIX is 4.3.3 ml09
Check if a patch is installed:
# instfix -i | grep iY24568
All FileSets for iY25282 befound
Said that there is this Patch.
# instfix -i | GREP IY30927
Not all filesets for iy30927.
Indicates that there is no IY30927 this patch
7. In particular, Java is not installed in the default installation of AIX 4.3.3, requiring manual installation.
(Do not handle it in AIX 5.1, the default installation of the system will install Java) at least JDK1.1.8, the corresponding patch is IY30886 If you use HTTP Server, you need JDK1.3.1, the corresponding patch is: IY31033
download link:
ftp://service.software.ibm.com/aix/efixes/
(If this patch has been installed, there will be a / usr / jdk_base directory, it is your java_home
8. Check if there is a desired OS package
AIX 4.3.3 requires the following packages:
Bos.Adt.base, bos.adt.lib, bos.adt.libm, bos.perf.perfstat
We can use the LSLPP PL OS_PACKAGE command to view:
# lslpp -l bos.adt.base
FileSet Level State Description
-------------------------------------------------- ----------------------------
PATH: / usr / lib / objrepos
Bos.Adt.base 4.3.3.77 Committed Base Application Developments
Toolkit
# lslpp -l bos.adt.lib
FileSet Level State Description
-------------------------------------------------- ----------------------------
PATH: / usr / lib / objrepos
Bos.Adt.lib 4.3.3.10 Committed Base Application DevelopmentLibraries
# lslpp -l bos.com.Adt.libm
FileSet Level State Description
-------------------------------------------------- ----------------------------
PATH: / usr / lib / objrepos
Bos.Adt.libm 4.3.3.50 Committed Base Application Developments
Math Library
#
9. After all of it finished, the Reboot machine:
Shutdown -fr
10. Check all the Patch and Package, now give the Oracle storage space
First, you need to store installation files in a place, assume that it is / oratools, we need to enter the Smit- System Storage Management (Physical & Logical Storage)
-File systems or -logical volume manager,
(If you are an AIX newbie, then you'd better choose FS, so that the system builds a logical volume for you, huh, huh;
If you want to install OPS or Rac, you have to use first logical volume, and then build a file system method, because the logical volume established by the system will be renamed)
-Add / change / show / delete file systems
-Journaled File Systems
-Add a journaled file system
- Add A Large File Enabled Journaled File System (Select this, you can support a file system greater than 2G)
This is the system that will make you choose a VG window. It is best not to choose rootvg because we usually put things related to the OS.
Then appear: Similar to the window below:
Size of File System (in 512-byte blocks) [] #
* Mount Point []
MOUNT Automatically at SystemArt? NO
(Note Mount Automatically At System Restart to Automatic MOUNT)
11. Create an Oracle_home home directory (method is the same as above)
12. Establish a DBA group
Smit Group - Add A Group
13. Establish Oracle users
Smit user - Add A User
14. Log in to Oracle, modify Profile, such as:
PATH = / usr / bin: / most / usr / sbin: / usr / ucb: $ homen / bin: / usr / bin / x11: / sbin :.
Export Path
IF [-s "$ mail"] # this is at shell startup. in Normalthen Echo "$ mailmsg" # Operation, The shell checks
Fi # periodically.
PATH = $ PATH: /ORATOOLS/gzip 1.2.4a
Export Path
DISPLAY = 192.168.2.216:0.0
EXPORT DISPLAY
Oracle_base = / oracle92
Export Oracle_Base
Oracle_Home = $ Oracle_Base / Product / 9.2
Export Oracle_home
Oracle_sid = ORA92
Export Oracle_sid
Oracle_Term = VT100
Export Oracle_Term
ORA_NLS33 = $ Oracle_Home / Ocommon / NLS / Admin / Data
Export ORA_NLS33
Java_home = / usr / jdk_base
Export java_home
LibPath = $ oracle_home / lib
Export Libpath
ClassPath = $ Oracle_Home / Product / Jlib: $ ORACLE_HOME / JLIB
Export ClassPath
PATH = $ oracle_home / bin: $ PATH
Export Path
NLS_LANG = American_America.zhs16GBK
Export NLS_LANG
TMPDIR = / oratools
Export Tmpdir
Set -o vi
Umask 022
15. Install Oracle, need XWindow support
Log in in Oracle, enter: XClock, see if you can have a small clock, if you can be ok
Otherwise, SU to root, then Xhost 192.168.2.216
16. There is nothing wrong with the rest, take a prompt, there will be a few times in the middle, and the root permission is required to implement a few SH, then OK
Note that when I installed IY30927, I was wrong when I was ignored, and then view the Make file and found a lot of problems, huh, huh, my solution:
First, install IY30927, then reboot;
Then, Relink
If there is still a problem with the following:
LD: 0711-317 error: undefined Symbol: ksusga_
LD: 0711-317 error: undefined Symbol: kwqpls_
LD: 0711-317 error: undefined Symbol: KCLNLT_
LD: 0711-317 error: undefined Symbol: ksulsg_
LD: 0711-317 error: undefined Symbol: KCBSTDBZ_
LD: 0711-345 Use the -bloadmap or -bnoquiet option to Obtain more information.
Make: The Error Code from the last command is 8.
So $ Oracle_Home / Lib, see if ksms.imp is 0 bytes, if yes, then remove this file, and execute Relink, because there is no problem. (This error is because when there is no IY30927, it prompts a .so error during the installation process, we have chosen ignored, then $ oracle_home / bin / genksms will fail, and in $ oracle_home / lib / ksms .imp produced the 0 BYTES file file) Recalling, I will basically appear above, I will reinstall it, and I will put it on the needed bag. It is estimated that there will be no later. Trouble, huh, huh.